OG shop member gallery
OldGobbler
          bullet Forum Board      bullet Pushpin Turkey Call Blog      bullet Advertising Info     

OG Gear Store

Sum Toy
Dave Smith
Wood Haven
North Mountain Gear
DC Cattle Ranch






Author Topic: Federal TSS Cycling Issues in Franchi Affinity 20 Gauge???  (Read 4217 times)

Offline SKFOOTER

  • Double Beard
  • *****
  • Posts: 2996
Federal TSS Cycling Issues in Franchi Affinity 20 Gauge???
« on: October 24, 2019, 12:23:55 PM »
Has anyone NOT had any cycling issues with their 20 gauge Affinity shooting the 3” Federal TSS loads??  I’ve read several threads about this being an issue due to the Federal hulls being a tad longer.

Offline AT

  • Sr. Member
  • **
  • Posts: 156
Re: Federal TSS Cycling Issues in Franchi Affinity 20 Gauge???
« Reply #1 on: October 24, 2019, 10:34:12 PM »
If you was interested in getting one, I wouldn’t let that stop me. It’s a pretty easy fix!! That’s all i shoot out of mine.

Offline PineyRooster

  • Full Member
  • *
  • Posts: 71
Re: Federal TSS Cycling Issues in Franchi Affinity 20 Gauge???
« Reply #2 on: October 27, 2019, 06:33:18 AM »
If you was interested in getting one, I wouldn’t let that stop me. It’s a pretty easy fix!! That’s all i shoot out of mine.

how did you fix the problem with yours?

Offline bluetick58

  • Full Member
  • *
  • Posts: 82
Re: Federal TSS Cycling Issues in Franchi Affinity 20 Gauge???
« Reply #3 on: November 28, 2019, 05:36:40 PM »
id like to know also about easy fix thanks

Offline SKFOOTER

  • Double Beard
  • *****
  • Posts: 2996
Re: Federal TSS Cycling Issues in Franchi Affinity 20 Gauge???
« Reply #4 on: November 28, 2019, 09:55:29 PM »
C’mon AT.  Spill the beans!!

Offline AT

  • Sr. Member
  • **
  • Posts: 156
Re: Federal TSS Cycling Issues in Franchi Affinity 20 Gauge???
« Reply #5 on: December 10, 2019, 10:28:53 PM »
Take your trigger assembly out and trim/sand the piece your shell hits when it comes out of the magazine. I sanded mine down smooth and re notched it. I’ll try to get some pics posted. It worked on mine but just remove a little bit at a time until it cycles correctly.