OG shop member gallery
OldGobbler
          bullet Forum Board      bullet Pushpin Turkey Call Blog      bullet Advertising Info     

OG Gear Store

Sum Toy
Dave Smith
Wood Haven
DC Cattle Ranch






Author Topic: SP-10 Not Cycling  (Read 3099 times)

Offline robbartley

  • Full Member
  • *
  • Posts: 29
SP-10 Not Cycling
« on: May 01, 2018, 06:42:20 AM »
Shot a turkey this morning and the second shell did not feed.  Same thing happened last year except it cost me a turkey because the second shell jammed.  Any ideas why and how to fix?

Offline tha bugman

  • 2019 SITE SUPPORTER
  • Paintbrush Beard
  • ********
  • Posts: 3639
Re: SP-10 Not Cycling
« Reply #1 on: May 01, 2018, 09:22:24 AM »
what shells are you using?, how old is the gun?, when was the last time taht you broke it down completely and cleaned it?

Offline robbartley

  • Full Member
  • *
  • Posts: 29
Re: SP-10 Not Cycling
« Reply #2 on: May 01, 2018, 01:33:38 PM »
I purchased the gun second hand about 5 years ago.  I have never completely broke the gun down in the time I have owned it and probably should.  From a youtube video I watched today it does not look all that difficult.  I will say though that this was not an issue prior to last year and I have shot the gun less that 20 times in the time I have owned it.  I am shooting Federals currently.

Offline tha bugman

  • 2019 SITE SUPPORTER
  • Paintbrush Beard
  • ********
  • Posts: 3639
Re: SP-10 Not Cycling
« Reply #3 on: May 01, 2018, 03:39:28 PM »
I purchased the gun second hand about 5 years ago.  I have never completely broke the gun down in the time I have owned it and probably should.  From a youtube video I watched today it does not look all that difficult.  I will say though that this was not an issue prior to last year and I have shot the gun less that 20 times in the time I have owned it.  I am shooting Federals currently.
I would start with a good cleaning and oiling, and see if that improves the cycling. 

Offline BTH

  • The Boss Gobbler
  • ****
  • Posts: 506
  • Proverbs 3:5-6. I like the snood!
Re: SP-10 Not Cycling
« Reply #4 on: May 02, 2018, 12:53:26 PM »
This may help you out for disassembly. It did me when I broke mine down for deep cleaning.The mag 10 and the SP 10 are virtually the same except the trigger group.
Phil 4:13

Offline tha bugman

  • 2019 SITE SUPPORTER
  • Paintbrush Beard
  • ********
  • Posts: 3639
Re: SP-10 Not Cycling
« Reply #5 on: May 03, 2018, 09:36:37 AM »
Just a recommendation before breakdown.  I would put a white sheet on the table that you are going to be working on as one time I broke my trigger assembly down only to have a small spring fall out.  I stopped immediately placed it in a zip lock and bee lined it to the gunsmith.

Offline robbartley

  • Full Member
  • *
  • Posts: 29
Re: SP-10 Not Cycling
« Reply #6 on: May 03, 2018, 11:51:11 AM »
Thanks for the help guys!

Offline Remingtonfan

  • Jr. Member
  • *
  • Posts: 16
Re: SP-10 Not Cycling
« Reply #7 on: May 13, 2018, 12:03:39 PM »
Rob, most time when this happens it just needs good cleaning,  sometimes it the exjecter spring, if shooting nitros watch out for it breaking that Cushing ring, and make sure u don't have no wax build up in barrel from wadding.
I purchased the gun second hand about 5 years ago.  I have never completely broke the gun down in the time I have owned it and probably should.  From a youtube video I watched today it does not look all that difficult.  I will say though that this was not an issue prior to last year and I have shot the gun less that 20 times in the time I have owned it.  I am shooting Federals currently.

Sent from my SM-N910V using Tapatalk


Offline Rkeifer

  • Jr. Member
  • *
  • Posts: 7
Re: SP-10 Not Cycling
« Reply #8 on: May 25, 2018, 08:12:18 AM »
Make sure that your slide extension buffer is in good shape.  I bought a used SP-10 that did not have one and started to have cycling issues because the magazine tube was bent.  I sent it for repairs and everything is fine now. 

Offline Old Gobbler

  • Administrator
  • Limbhanger
  • *****
  • Posts: 4328
Re: SP-10 Not Cycling
« Reply #9 on: August 08, 2018, 03:28:06 PM »
If your magazine and cycle springs have gone "limp " swap them out for Wolfe extra power springs , they only make them for Ithaca mag10, bit the function flawlessly in a sp10

 :wave:  OG .....DRAMA FREE .....

Sorry guys... the THE BOOKS ARE CLOSED on Push Pin Turkey  calls.... I wont be accepting anymore names to the list untill I catch up on orders.the books will be closed  a few years minimum

-Shannon

Online wchadw

  • The Boss Gobbler
  • ****
  • Posts: 826
  • Shoot em in the pecker
Re: SP-10 Not Cycling
« Reply #10 on: August 08, 2018, 03:35:35 PM »
Shot a turkey this morning and the second shell did not feed.  Same thing happened last year except it cost me a turkey because the second shell jammed.  Any ideas why and how to fix?
I had this problem with my beretta with long beard XR shells. I switched to a TSS shell and the cycle fine


Sent from my iPhone using Tapatalk

Offline Roosted aint Roasted

  • Jr. Member
  • *
  • Posts: 8
Re: SP-10 Not Cycling
« Reply #11 on: January 26, 2019, 03:45:35 PM »
I shoot an SP-10 and it will do the same thing if not clean.    I give mine a good cleaning prior to the season every year.

Offline Old Gobbler

  • Administrator
  • Limbhanger
  • *****
  • Posts: 4328
Re: SP-10 Not Cycling
« Reply #12 on: January 28, 2019, 07:49:50 AM »
For a sp10 , if I remember correctly from the manual --the bolt face bust be clean , and clean from oils residue etc..

 :wave:  OG .....DRAMA FREE .....

Sorry guys... the THE BOOKS ARE CLOSED on Push Pin Turkey  calls.... I wont be accepting anymore names to the list untill I catch up on orders.the books will be closed  a few years minimum

-Shannon

Offline tha bugman

  • 2019 SITE SUPPORTER
  • Paintbrush Beard
  • ********
  • Posts: 3639
Re: SP-10 Not Cycling
« Reply #13 on: January 28, 2019, 10:24:40 AM »
I got to thinking this weekend that I sure hope we can continue to find parts for the SP-10 in the future without having to pay out the nose.

Offline Gen.27:3

  • The Boss Gobbler
  • ****
  • Posts: 570
Re: SP-10 Not Cycling
« Reply #14 on: February 27, 2019, 11:37:36 PM »
I got to thinking this weekend that I sure hope we can continue to find parts for the SP-10 in the future without having to pay out the nose.


I agree, I have hunted with an sp-10 for several years, And I have never had trouble with them. But I do hope that parts don't become too expensive for them.
« Last Edit: April 27, 2019, 04:35:57 PM by Gen.27:3 »
Gen 27:3  Now then, take your weapons, your quiver and your bow, and go out to the field and hunt game for me,